Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-14-02, 11:18 AM   #1
knchee
Registered User
 
Join Date: Sep 2002
Posts: 11
Default Need help to get the X to work on my Acer TravelMate 630

Recently, I tried to install the RH 7.2 on my Acer TravelMate 630 and to get it working. During the installation, every things went fine (RH 7.2 event auto detect the Nvidia Gforce 2 Go) until the part where it need to input the data for the Monitor. I can not find a match in the list for my nootbook LCD screen with a resolution 7024 x 768. I went on to use Custom manual setup where I entered the closest value ( I think!) and when the installation process tried to probe my Monitor, my screen went blur and I can't read any thing off the screen. All I can do next is to reboot my notebook and tried on different sets of value and they all fail.

I was advised to download from the net the driver NVIDIA_kernel-1.0-2960.tar.gz and NVIDIA_GLX-1.0-2960.tar.gz and installed with (tar xvzf NVIDIA_kernel-1.0-2960.tar.gz, tar xvzf NVIDIA_GLX-1.0-2960.tar.gz, cd NVIDIA_kernel-1.0-2960, make install, cd ../NVIDIA_GLX, make install). During the "make install" in NVIDIA_kernel-1.0-2960 directory, the error message in sttached herewith in 'install.error'. I edited the /etc/X11/XF86Config-4 as described in the Nvidia website. When I tried to startx X regardlessly, the on screen error message in attached in the file 'XFree86.0.log'.

I have no clue of what went wrong, I AM A COMPLETE NEWBIE! I really hope that you would help me and guide me through step-by-step to make X can work on my notebook.

Thank you and looking forward to receiving a reply from you soon. I have spent nights on this and it still refuse to work, it really start to drive me crazy!.

Oswald
knchee is offline   Reply With Quote
Old 09-14-02, 01:59 PM   #2
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

As a complete newbie, as you write, why do you try to run compilers on your linux system?
Klaus-P is offline   Reply With Quote
Old 09-15-02, 04:58 AM   #3
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

Oh, sorry something has been going wrong with my response. Well

You wrote resolution "7024x768" , either this is a misprint or you
mean 1024x768.

Well it's a bit confusing indeed. NVIDIA_kernel-1.0.2960.tar.gz
contains source code. Read the passage in the README where you are
advised to enter "cd ../NVIDIA_kernel... ", etc....
So there is a problem with your compiler on your system.
enter "gcc -v" and , if a you get a "command not found" it is very
likely that the gcc-package is perhaps not installed.If you are going to install
it you must also install the complete kernel sources of your Rh 7.2.
But you don't need a compiler to run Linux and or the nvidia drivers
whenever all programs, drivers, modules, etc,..are precompiled and linked.
Try to download those RPM-packages with precompiled drivers for RedHat 7.2
and follow the instructions there.
Klaus-P is offline   Reply With Quote
Old 09-15-02, 10:53 AM   #4
knchee
Registered User
 
Join Date: Sep 2002
Posts: 11
Default

Thank you for the advise.

As suggessted, I downloaded the (1) NVIDIA_kernel-1.0-2960.rh72up.i386.rpm and NVIDIA_GLX-1.0-2960.i386.rpm. I installed them with "rpm -ivh ........" as per README instsructed. I double confirmed the two file are installed. However, when I "startx", the harddist start to spin and it end's up with the error message on the screen. I attached the xfree86.0.log file for reference. Have I downloaded the wrong files or something else I missed? Appreciate for any help.

Thank you.
Attached Files
File Type: txt xfree86.txt (0, 282 views)
knchee is offline   Reply With Quote
Old 09-15-02, 01:08 PM   #5
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

Your attachment file seems to contain no data.
Just put it here on the board.
Klaus-P is offline   Reply With Quote
Old 09-16-02, 10:45 AM   #6
knchee
Registered User
 
Join Date: Sep 2002
Posts: 11
Default

Sorry, the following is my XFree86.0.log : -

XFree86 Version 4.1.0 (Red Hat Linux release: 4.1.0-3) / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 2 June 2001
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/FAQ)
Build Operating System: Linux 2.4.7-0.13.1smp i686 [ELF]
Build Host: stripples.devel.redhat.com

Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Thu Sep 12 23:25:53 2002
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) ServerLayout "Anaconda Configured"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "NVIDIA GeForce 2 Go (generic)"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc105"
(**) XKB: model: "pc105"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) FontPath set to "unix/:7100"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.4
XFree86 XInput driver : 0.2
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.2
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x8000993c, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 10b9,1671 card 0000,0000 rev 02 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 10b9,5247 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:06:0: chip 10b9,5451 card 1025,1018 rev 02 class 04,01,00 hdr 00
(II) PCI: 00:07:0: chip 10b9,1533 card 1025,102b rev 00 class 06,01,00 hdr 00
(II) PCI: 00:08:0: chip 10b9,5457 card 1025,102b rev 00 class 07,03,00 hdr 00
(II) PCI: 00:0a:0: chip 10ec,8139 card 1025,102b rev 10 class 02,00,00 hdr 00
(II) PCI: 00:0b:0: chip 1106,3044 card 1106,3044 rev 46 class 0c,00,10 hdr 00
(II) PCI: 00:0f:0: chip 10b9,5237 card 1025,102b rev 03 class 0c,03,10 hdr 00
(II) PCI: 00:10:0: chip 10b9,5229 card 1025,102b rev c4 class 01,01,8a hdr 00
(II) PCI: 00:11:0: chip 10b9,7101 card 1025,102b rev 00 class 06,80,00 hdr 00
(II) PCI: 00:13:0: chip 1217,6933 card 0001,0000 rev 02 class 06,07,00 hdr 82
(II) PCI: 00:13:1: chip 1217,6933 card 0001,0000 rev 02 class 06,07,00 hdr 82
(II) PCI: 00:14:0: chip 10b9,5237 card 1025,102b rev 03 class 0c,03,10 hdr 00
(II) PCI: 01:00:0: chip 10de,0112 card 1025,102b rev b2 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) PCI-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0x00000000 - 0xffffffff (0x0) MX[b]
(II) Bus 0 prefetchable memory range:
[0] -1 0x00000000 - 0xffffffff (0x0) MX[b]
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x0c (VGA_EN is set)
(II) Bus 1 I/O range:
(II) Bus 1 non-prefetchable memory range:
[0] -1 0xe1000000 - 0xe1ffffff (0x1000000) MX[b]
(II) Bus 1 prefetchable memory range:
[0] -1 0xe8000000 - 0xefffffff (0x8000000) MX[b]
(II) Bus -1: bridge is at (0:7:0), (0,-1,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI:*(1:0:0) NVidia unknown chipset (0x0112) rev 178, Mem @ 0xe1000000/24, 0xe8000000/27
(II) Addressable bus resource ranges are
[0] -1 0x00000000 - 0xffffffff (0x0) MX[b]
[1] -1 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) OS-reported resource ranges:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0x0000ffff - 0x0000ffff (0x1) IX[b]
[6] -1 0x00000000 - 0x000000ff (0x100) IX[b]
(II) Active PCI resource ranges:
[0] -1 0xe0004000 - 0xe0004fff (0x1000) MX[b]
[1] -1 0xe0003000 - 0xe0003fff (0x1000) MX[b]
[2] -1 0xe0002800 - 0xe0002fff (0x800) MX[b]
[3] -1 0xe0002000 - 0xe00020ff (0x100) MX[b]
[4] -1 0xe0001000 - 0xe0001fff (0x1000) MX[b]
[5] -1 0xe0000000 - 0xe0000fff (0x1000) MX[b]
[6] -1 0xf0000000 - 0xf7ffffff (0x8000000) MX[b]
[7] -1 0xe8000000 - 0xefffffff (0x8000000) MX[b](B)
[8] -1 0xe1000000 - 0xe1ffffff (0x1000000) MX[b](B)
[9] -1 0x00002480 - 0x0000248f (0x10) IX[b]
[10] -1 0x00002400 - 0x0000247f (0x80) IX[b]
[11] -1 0x00002000 - 0x000020ff (0x100) IX[b]
[12] -1 0x00001c00 - 0x00001cff (0x100) IX[b]
[13] -1 0x00001800 - 0x000018ff (0x100) IX[b]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0xe0004000 - 0xe0004fff (0x1000) MX[b]
[1] -1 0xe0003000 - 0xe0003fff (0x1000) MX[b]
[2] -1 0xe0002800 - 0xe0002fff (0x800) MX[b]
[3] -1 0xe0002000 - 0xe00020ff (0x100) MX[b]
[4] -1 0xe0001000 - 0xe0001fff (0x1000) MX[b]
[5] -1 0xe0000000 - 0xe0000fff (0x1000) MX[b]
[6] -1 0xf0000000 - 0xf7ffffff (0x8000000) MX[b]
[7] -1 0xe8000000 - 0xefffffff (0x8000000) MX[b](B)
[8] -1 0xe1000000 - 0xe1ffffff (0x1000000) MX[b](B)
[9] -1 0x00002480 - 0x0000248f (0x10) IX[b]
[10] -1 0x00002400 - 0x0000247f (0x80) IX[b]
[11] -1 0x00002000 - 0x000020ff (0x100) IX[b]
[12] -1 0x00001c00 - 0x00001cff (0x100) IX[b]
[13] -1 0x00001800 - 0x000018ff (0x100) IX[b]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0x0000ffff - 0x0000ffff (0x1) IX[b]
[6] -1 0x00000000 - 0x000000ff (0x100) IX[b]
(II) All system resource ranges:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0xe0004000 - 0xe0004fff (0x1000) MX[b]
[6] -1 0xe0003000 - 0xe0003fff (0x1000) MX[b]
[7] -1 0xe0002800 - 0xe0002fff (0x800) MX[b]
[8] -1 0xe0002000 - 0xe00020ff (0x100) MX[b]
[9] -1 0xe0001000 - 0xe0001fff (0x1000) MX[b]
[10] -1 0xe0000000 - 0xe0000fff (0x1000) MX[b]
[11] -1 0xf0000000 - 0xf7ffffff (0x8000000) MX[b]
[12] -1 0xe8000000 - 0xefffffff (0x8000000) MX[b](B)
[13] -1 0xe1000000 - 0xe1ffffff (0x1000000) MX[b](B)
[14] -1 0x0000ffff - 0x0000ffff (0x1) IX[b]
[15] -1 0x00000000 - 0x000000ff (0x100) IX[b]
[16] -1 0x00002480 - 0x0000248f (0x10) IX[b]
[17] -1 0x00002400 - 0x0000247f (0x80) IX[b]
[18] -1 0x00002000 - 0x000020ff (0x100) IX[b]
[19] -1 0x00001c00 - 0x00001cff (0x100) IX[b]
[20] -1 0x00001800 - 0x000018ff (0x100) IX[b]
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) LoadModule: "fbdevhw"
(II) Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Module fbdevhw: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 0.0.2
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "pex5"
(II) Loading /usr/X11R6/lib/modules/extensions/libpex5.a
(II) Module pex5: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension X3D-PEX
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.2960
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "pex5"
(II) Reloading /usr/X11R6/lib/modules/extensions/libpex5.a
(II) Loading extension X3D-PEX
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.13.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension RECORD
(II) LoadModule: "xie"
(II) Loading /usr/X11R6/lib/modules/extensions/libxie.a
(II) Module xie: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension XIE
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.2960
Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.2
(II) NVIDIA XFree86 Driver 1.0-2960 Tue May 14 07:45:20 PDT 2002
(II) NVIDIA: NVIDIA driver for: RIVA TNT, RIVA TNT2, Vanta,
RIVA TNT2 Ultra, RIVA TNT2 Model 64, Aladdin TNT2, GeForce 256,
GeForce DDR, Quadro, GeForce2 MX/MX 400, GeForce2 MX 100/200,
Quadro2 MXR/EX/Go, GeForce2 Integrated GPU, GeForce2 GTS,
GeForce2 Ti, GeForce2 Ultra, Quadro2 Pro, GeForce4 MX 460,
GeForce4 MX 440, GeForce4 MX 420, Quadro4 500/550 XGL,
Quadro4 200/400 NVS, GeForce3, GeForce3 Ti 200, GeForce3 Ti 500,
Quadro DCC, GeForce4 Ti 4600, GeForce4 Ti 4400, GeForce4 Ti 4200,
Quadro4 900 XGL, Quadro4 750 XGL, Quadro4 700 XGL, GeForce2 Go,
GeForce4 440 Go, GeForce4 420 Go, GeForce4 420 Go 32M,
GeForce4 440 Go 64M, Quadro4 500 GoGL
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset GeForce2 Go found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0xe0004000 - 0xe0004fff (0x1000) MX[b]
[6] -1 0xe0003000 - 0xe0003fff (0x1000) MX[b]
[7] -1 0xe0002800 - 0xe0002fff (0x800) MX[b]
[8] -1 0xe0002000 - 0xe00020ff (0x100) MX[b]
[9] -1 0xe0001000 - 0xe0001fff (0x1000) MX[b]
[10] -1 0xe0000000 - 0xe0000fff (0x1000) MX[b]
[11] -1 0xf0000000 - 0xf7ffffff (0x8000000) MX[b]
[12] -1 0xe8000000 - 0xefffffff (0x8000000) MX[b](B)
[13] -1 0xe1000000 - 0xe1ffffff (0x1000000) MX[b](B)
[14] -1 0x0000ffff - 0x0000ffff (0x1) IX[b]
[15] -1 0x00000000 - 0x000000ff (0x100) IX[b]
[16] -1 0x00002480 - 0x0000248f (0x10) IX[b]
[17] -1 0x00002400 - 0x0000247f (0x80) IX[b]
[18] -1 0x00002000 - 0x000020ff (0x100) IX[b]
[19] -1 0x00001c00 - 0x00001cff (0x100) IX[b]
[20] -1 0x00001800 - 0x000018ff (0x100) IX[b]
(II) resource ranges after probing:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0xe0004000 - 0xe0004fff (0x1000) MX[b]
[6] -1 0xe0003000 - 0xe0003fff (0x1000) MX[b]
[7] -1 0xe0002800 - 0xe0002fff (0x800) MX[b]
[8] -1 0xe0002000 - 0xe00020ff (0x100) MX[b]
[9] -1 0xe0001000 - 0xe0001fff (0x1000) MX[b]
[10] -1 0xe0000000 - 0xe0000fff (0x1000) MX[b]
[11] -1 0xf0000000 - 0xf7ffffff (0x8000000) MX[b]
[12] -1 0xe8000000 - 0xefffffff (0x8000000) MX[b](B)
[13] -1 0xe1000000 - 0xe1ffffff (0x1000000) MX[b](B)
[14] 0 0x000a0000 - 0x000affff (0x10000) MS[b]
[15] 0 0x000b0000 - 0x000b7fff (0x8000) MS[b]
[16] 0 0x000b8000 - 0x000bffff (0x8000) MS[b]
[17] -1 0x0000ffff - 0x0000ffff (0x1) IX[b]
[18] -1 0x00000000 - 0x000000ff (0x100) IX[b]
[19] -1 0x00002480 - 0x0000248f (0x10) IX[b]
[20] -1 0x00002400 - 0x0000247f (0x80) IX[b]
[21] -1 0x00002000 - 0x000020ff (0x100) IX[b]
[22] -1 0x00001c00 - 0x00001cff (0x100) IX[b]
[23] -1 0x00001800 - 0x000018ff (0x100) IX[b]
[24] 0 0x000003b0 - 0x000003bb (0xc) IS[b]
[25] 0 0x000003c0 - 0x000003df (0x20) IS[b]

My posting is too long I need to split it into two.


Thanks.
knchee is offline   Reply With Quote
Old 09-16-02, 10:46 AM   #7
knchee
Registered User
 
Join Date: Sep 2002
Posts: 11
Default

This second half of my XFree86.0.log: -

(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(**) NVIDIA(0): Depth 16, (--) framebuffer bpp 16
(==) NVIDIA(0): RGB weight 565
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xE8000000
(--) NVIDIA(0): MMIO registers at 0xE1000000
(EE) NVIDIA(0): Failed to initialize the NVdriver kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.


Thanks
knchee is offline   Reply With Quote
Old 09-16-02, 11:36 AM   #8
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Looks like you need to modprobe NVdriver as root before you startx.

You can automate this by (let's see... RH 7.2...) adding an alias to /etc/modules.conf, but the alias depends on what's in your /dev directory. If almost everything in /dev shows up in yellow, making them all devices (I believe the color scheme for ls is the same in RH as it was in Mandrake...), then you need to make sure there are files in there named nvidiactl, nvidia0, nvidia1, nvidia2, and nvidia3. Then add a line to /etc/modules.conf looking like this:

alias char-major-195 NVdriver

If, on the other hand, almost everything in /dev is a symlink (shows up in cyan/light blue), then your alias line should look like this:

alias /dev/nvidia* NVdriver

After you've made the change, it should work after a reboot. If you just manually modprobe NVdriver, then it'll work only until you reboot.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote

Old 09-16-02, 11:51 PM   #9
knchee
Registered User
 
Join Date: Sep 2002
Posts: 11
Default

I tried "modprobe NVdriver" and the following error message appeared

/lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol__Pollwait.R6dac8142
/lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol__Proc_root_driver_rec82fe4f
/lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol__init_mm_Rb295fff9
/lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol__Proc_root_Rd53464da
/lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol__irq_stat_R67732e05
/lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol__Create_proc_entry_Rb7ba90c7
/lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol__register_chrdev_R827e2e0f
/lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol__remove_proc_entry_Rf691595b
/lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: unresolved symbol__mem_map_Rfbcd42f
/lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: insmod /lib/modules/2.4.7-10/kernel/drivers/video/NVdriver failed
/lib/modules/2.4.7-10/kernel/drivers/video/NVdriver: insmod NVdriver failed

I must have done something else wrong. Please help.

Thanks
knchee is offline   Reply With Quote
Old 09-17-02, 06:14 AM   #10
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

Enter a "cat /proc/version" and check the version datas. Then
compare with the Redhat nvidia kernel file you've downloaded.
There are several RedHat7.2 rmp-files available for different
Linux system kernels.
Do also try a "depmod" and a "depmod -a"
Klaus-P is offline   Reply With Quote
Old 09-17-02, 10:37 AM   #11
knchee
Registered User
 
Join Date: Sep 2002
Posts: 11
Default

Hi! As suggested, I entered "cat /proc/version" and got a return

Linux version 2.4.7-10 (bhcompile@stripples.devel.redhat.com) (gcc version 2.9620000731 (Red Hat Linux 7.1 2.96-98)) #1 Thu Sep 6 17:27:27 EDT 2001

I then entered "depmod" and "depmod -a" and both return with

depmod: *** Unresolved symbols in /lib/module/2.4.7-10/kernel/drivers/video/NVdriver

What's all these mean?!!

The two rpm files I install are NVIDIA_kernel-1.0-2960.rh72.i386.rpm and NVIDIA_GLX-1.0-2960.I386.rpm. Are these files the right one?

I also tried to compile NVIDIA_kernel.tar.gz and NVIDIA_GLX.tar.gz. No luck so far!

What can I do next?

Thanks for your further advise.
knchee is offline   Reply With Quote
Old 09-17-02, 10:52 AM   #12
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Try downloading the NVchooser.sh file (it's referenced somewhere on the driver download page) and running it with sh NVchooser.sh -- it should tell you the version of driver to install. Remove the old NVIDIA_kernel RPM, and install the one it tells you to use.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stereo 3D Video Playback on Acer Iconia Tab W700 Windows 8 Tablet News Archived News Items 0 11-09-12 10:00 AM
Keep up the good work NVIDIA! cheechr1 NVIDIA Linux 3 11-06-12 12:18 AM
nVidia GeForce 630 also pixelated News Archived News Items 0 06-01-12 05:30 AM
295.49 fails on Acer 5755G under Ubuntu 10.04 AdrianMay NVIDIA Linux 2 05-09-12 06:07 AM
295.40 Does not Work Had to downgrade to 295.33 Archmbc NVIDIA Linux 4 05-03-12 02:38 PM

All times are GMT -5. The time now is 08:33 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.