Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-29-10, 12:41 AM   #1
terau
Registered User
 
Join Date: Aug 2010
Posts: 19
Default VDPAU hangs/freezes even with 256.52

I was waiting for this new release to fix my VDPAU issues with my GTX460, but still no go with the new pre-release drivers. So I think it is time to post here.

Sometimes when I start playing a video with (-vo vdpau) mplayer, the system stops responding (even mouse can't be moved) for some seconds (~7secs).

A full proof way to trigger the bug is if I press "f" (toggle full screen) many times doing playback, or by rapidly resizing the video window, the temporary hang always happens then.

It also happens with VLC vaapi-vdpau, not only with mplayer.

Everything else (opengl, 3d compiz etc) works fine, with zero problems.I only get hangs when vdpau is used.

I tried VDPAU_TRACE but it doesn't show any errors.

I am using Gentoo stable amd64 with xorg 1.7.7.

Any ideas?
terau is offline   Reply With Quote
Old 08-29-10, 02:54 AM   #2
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: VDPAU hangs/freezes even with 256.52

If you want vdpau hardware decoding you should start with
mplayer -vo vdpau -vc ffh264vdpau, ffmpeg12vdpau, ffwmv3vdpau, ffvc1vdpau, ffh264vdpau, ffodivxvdpau moviename

Edit: do yuo run a compositing manager such as mutter?
gradinaruvasile is offline   Reply With Quote
Old 08-29-10, 05:17 AM   #3
terau
Registered User
 
Join Date: Aug 2010
Posts: 19
Default Re: VDPAU hangs/freezes even with 256.52

The problem exists with compositing manager or not.

As long as the output is vdpau with the hardware vdpau codecs the hangs appear, if I use software codecs the hangs disappear.
terau is offline   Reply With Quote
Old 08-29-10, 06:09 AM   #4
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: VDPAU hangs/freezes even with 256.52

Quote:
Originally Posted by terau View Post
I was waiting for this new release to fix my VDPAU issues with my GTX460, but still no go with the new pre-release drivers. So I think it is time to post here.

Sometimes when I start playing a video with (-vo vdpau) mplayer, the system stops responding (even mouse can't be moved) for some seconds (~7secs).
can you read http://www.nvnews.net/vbulletin/showthread.php?t=46678 and generate a good report with the debug info as instructed after the issue appears ?
also attach the mplayer output
Licaon is offline   Reply With Quote
Old 08-30-10, 10:39 AM   #5
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU hangs/freezes even with 256.52

terau,

It sounds like you may have multiple ways to reproduce your issue?

Our next driver release series after r260 fixed a bug described as "Fixed a bug in VDPAU that could cause a 'display preemption' when toggling MPlayer to full-screen the first time." Does that sound like your issue? Do you use the "-fs" (full-screen) option to MPlayer?

If not, or if you do have multiple issues, then please provide an nvidia-bug-report, and details of the other issues you're having. Thanks.
Stephen Warren is offline   Reply With Quote
Old 08-30-10, 06:15 PM   #6
jcornwall
Registered User
 
Join Date: Aug 2007
Location: Austin, TX
Posts: 120
Default Re: VDPAU hangs/freezes even with 256.52

I also raised this issue in http://www.nvnews.net/vbulletin/showthread.php?t=154261 on a 470 with 256.44 drivers. Bug report in there.
jcornwall is offline   Reply With Quote
Old 08-31-10, 01:42 AM   #7
terau
Registered User
 
Join Date: Aug 2010
Posts: 19
Default Re: VDPAU hangs/freezes even with 256.52

Quote:
Originally Posted by Stephen Warren View Post
terau,

It sounds like you may have multiple ways to reproduce your issue?

Our next driver release series after r260 fixed a bug described as "Fixed a bug in VDPAU that could cause a 'display preemption' when toggling MPlayer to full-screen the first time." Does that sound like your issue? Do you use the "-fs" (full-screen) option to MPlayer?

If not, or if you do have multiple issues, then please provide an nvidia-bug-report, and details of the other issues you're having. Thanks.
I doesn't happen only in full screen mode. The freeze seems to trigger when vdpau initializes or the window size is changed (be it full screen or not).

I will post a bug report later.
terau is offline   Reply With Quote
Old 09-04-10, 11:58 AM   #8
terau
Registered User
 
Join Date: Aug 2010
Posts: 19
Default Re: VDPAU hangs/freezes even with 256.52

Ok I have some new info for this freeze/hang problem.

I increased the mplayer cache to ~32M and the problems disappeared.

I was playing the video from network, so the cache wasn't enough for the network latency.

However using XV, the video just dropped some frames because of the low cache / network latency.

When VDPAU is used, the whole system gets frozen instead of frame skipping like XV when low on cache. It seems to me that vdpau makes the whole system wait for the "next" stream in case it gets delayed for whatever reason.

It should just make mplayer fail not the whole system.

The massive resize/fullscreen seems to temporarily disable mplayer's "stream input", that's why the bug happened more often there.

Is there a known problem about this?
terau is offline   Reply With Quote

Old 09-07-10, 02:48 PM   #9
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU hangs/freezes even with 256.52

We're aware of some bugs when toggling full-screen or resizing windows. Some have been fixed and will be included in the next driver release. We're still investigating some others.
Stephen Warren is offline   Reply With Quote
Old 09-08-10, 09:06 AM   #10
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: VDPAU hangs/freezes even with 256.52

I'm also seeing this freeze with my GTX460 and 256.53 or 260.19.04 in qvdpautest during the test "H264 DECODING (1920x1080)".
Lysius is offline   Reply With Quote
Old 09-08-10, 04:31 PM   #11
terau
Registered User
 
Join Date: Aug 2010
Posts: 19
Default Re: VDPAU hangs/freezes even with 256.52

Well it seems my mplayer "cache" theory was wrong, freezes always happen on massive resize/fullscreen.

260.19.04 didn't help.

For the sake of it, I also tried vdpau with FreeBSD 8.1, in case the problem was linux specific, and there the system completely hangs (not temp freeze like linux) with sound loop.
terau is offline   Reply With Quote
Old 09-15-10, 04:31 PM   #12
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: VDPAU hangs/freezes even with 256.52

Still seems to be present in 260.19.06
Lysius is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:47 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.