Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-06-12, 10:14 AM   #37
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: 302.07 no resume from suspend

Quote:
Originally Posted by artem View Post
Danix, you've always supported VesaFB, why have you changed your mind?

Either provide us with a working KMS or revert the changes which made VesaFB unusable. Many of us use text consoles and running 27" monitors at 80x25 resolution seems like a crazy idea.
Artem, something just happening to work is not the same thing as supporting it; there wasn't a specific change designed to intentionally break FB consoles contrary to what you're implying. We're still trying to find what changed in that regard in case it's an easy fix, but if it's not keep in mind this was never an officially supported configuration. If you're unhappy with a 80x25 console on your 27" DFP, try the following program:

www.x.org
Plagman is offline   Reply With Quote
Old 06-06-12, 10:30 AM   #38
artem
Registered User
 
Join Date: Jun 2006
Posts: 705
Default Re: 302.07 no resume from suspend

Plagman

I didn't mean to shout or offend any of NVIDIA developers, I'm sorry if I chose the wrong words to voice my concern.

From your words ("non-VGA consoles are not supported") it just became clear to me that you no longer want to support VesaFB . Again I'm sorry if I misunderstood your statement.

On a bright note I'm already using this application.
artem is offline   Reply With Quote
Old 06-06-12, 12:45 PM   #39
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: 302.07 no resume from suspend

artem: Sorry if there was any confusion. Like Plagman said, we've never supported vesafb; it used to be the case that it happened to "just work", but now it doesn't. We're trying to figure out what happened, but since we don't understand exactly what happened yet, we can't promise that it will be fixed. Even if we do end up fixing it, please don't take that as a sign that we support non-VGA consoles.

ltmon: This is still showing up in your dmesg:

Code:
[    4.086429] uvesafb: NVIDIA Corporation, NVIDIA Quadro FX 880M
[    4.086436] , Chip Rev   , OEM: NVIDIA, VBE v3.0
[    4.137836] uvesafb: VBIOS/hardware doesn't support DDC transfers
[    4.137842] uvesafb: no monitor limits have been set, default refresh rate will be used
[    4.138236] uvesafb: scrolling: redraw
[    4.298646] Console: switching to colour frame buffer device 106x30
[    4.299447] uvesafb: framebuffer at 0xcf000000, mapped to 0xffffc90011c00000, using 8000k, total 14336k
[    4.299449] fb0: VESA VGA frame buffer device
It doesn't look like your kernel command line explicitly requests the framebuffer console (unlike the previous kernel command line, which is still visible in the old logs, and did explicitly configure uvesafb), and I'm not really sure where it's coming from. Try removing the "splash" option from your command line. If that doesn't help, maybe try blacklisting uvesafb and vesafb in /etc/modprobe.d and rebuild your initrd.
danix is offline   Reply With Quote
Old 06-06-12, 02:00 PM   #40
artem
Registered User
 
Join Date: Jun 2006
Posts: 705
Default Re: 302.07 no resume from suspend

danix

Is there a hope that you'll implement KMS support in the future? I guess it'll be even better than trying to fix the broken interaction between X.org/nvidia drivers and vesafb.
artem is offline   Reply With Quote
Old 06-06-12, 02:41 PM   #41
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: 302.07 no resume from suspend

Disabling vesafb does not help here ...
Log attached.
Attached Files
File Type: gz nvidia-bug-report.log.gz (124.4 KB, 51 views)
Dragoran is offline   Reply With Quote
Old 06-06-12, 06:59 PM   #42
ltmon
Registered User
 
Join Date: Mar 2004
Location: Melbourne, Australia
Posts: 9
Default Re: 302.07 no resume from suspend

Sorry for the false start, but disabling uvesafb properly doesn't fix the resume to black screen.

uvesfb module is blacklisted
Kernel options: quiet gfxpayload=text

New bug report attached.

On a side note, the nvidia-bug-report doesn't seem to show the kernel boot parameters correctly: it's picking up old ones all the time including the previous kernel version. I've made extra sure that I'm booting with the options I've specified here.
Attached Files
File Type: gz nvidia-bug-report.log.gz (71.7 KB, 69 views)
ltmon is offline   Reply With Quote
Old 06-07-12, 03:25 PM   #43
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: 302.07 no resume from suspend

Thanks for the updated logs. A normal VGA console seems to be used in both of those cases. The only reproduction of this issue that we have internally so far requires a non-VGA console, so it looks like we'll have to try harder to reproduce this issue.

I realize that this is all very frustrating, but please understand that we have attempted to reproduce this on many systems, and so far, we've only been able to reproduce it on non-VGA consoles. We're getting close to finding a root cause for the regression in the fb console case, but if you are seeing this issue even with a VGA console, then we can't be sure whether the issues are related until we can get this issue to occur on a system with a VGA console as well.

Has anybody who is affected by this issue been able to confirm that switching to a VGA console *does* allow resume to complete successfully?
danix is offline   Reply With Quote
Old 06-07-12, 06:17 PM   #44
d_u_s_t
Registered User
 
Join Date: Sep 2006
Location: Berlin
Posts: 18
Default Re: 302.07 no resume from suspend

I can confirm this issue on 302.11 and kernel 3.3 with AND without text console

The last working driver is 295.49! If I use a newer version I run into the resume bug: I press the hardware power button and the computer gets woken up but screen stays black, keyboard is locked up and SSH is unreachable.
I don't know if it is of importance: The Power LED keeps blinking (as it does when in STR state) and not even the reset button brings the machine back to life. I have to completely switch off power!! This is reproducible. Looks like driver puts the card (GTS450) into a state where it completely screws up the whole computer.

PS: I can gladly go without it, but having a framebuffer console and (more or less fancy) startup/shutdown animation has been state of the art for years! Please rethink your decision to not officially support it.
Attached Files
File Type: gz nvidia-bug-report.log.gz (66.3 KB, 49 views)
d_u_s_t is offline   Reply With Quote

Old 06-07-12, 08:46 PM   #45
ltmon
Registered User
 
Join Date: Mar 2004
Location: Melbourne, Australia
Posts: 9
Default Re: 302.07 no resume from suspend

Switching to VT (ctrl-alt-F2) and then suspend (sudo pm-suspend) works fine, and resumes to the console.

Switching back to X (ctrl-alt-F7) is then a frozen black screen.

Restarting X before switching back (sudo restart lightdm) works fine.

I believe this was the case with or without a vesa fb.

Quote:
Originally Posted by danix View Post
I realize that this is all very frustrating, but please understand that we have attempted to reproduce this on many systems
No problem, the word beta still has some meaning
ltmon is offline   Reply With Quote
Old 06-08-12, 05:27 AM   #46
d_u_s_t
Registered User
 
Join Date: Sep 2006
Location: Berlin
Posts: 18
Default Re: 302.07 no resume from suspend

For me it also happens when suspending from text console

The problem is, that 295.53 shows the same behaviour (at least for me, anyone else? ) and that 295.49 doesn't compile with kernel 3.4.
d_u_s_t is offline   Reply With Quote
Old 06-08-12, 06:17 AM   #47
MsTiFtS
Registered User
 
Join Date: Apr 2006
Posts: 6
Default Re: 302.07 no resume from suspend

Quote:
Originally Posted by danix View Post
Hi folks,

We have been able to reproduce a difference in functionality between the 295 and 302 drivers as described in this thread (display is black after suspend/resume in 302 and is fine in 295); however, we are only able to reproduce this symptom when running with a framebuffer console. The NVIDIA driver requires that the primary display device drive a VGA text console; non-VGA consoles are not supported.

While reviewing the nvidia-bug-report.log files attached to this thread so far, we noticed that most people appeared to be using framebuffer consoles.
Quote:
Originally Posted by ltmon View Post
Switching to VT (ctrl-alt-F2) and then suspend (sudo pm-suspend) works fine, and resumes to the console.

Switching back to X (ctrl-alt-F7) is then a frozen black screen.

Restarting X before switching back (sudo restart lightdm) works fine.

I believe this was the case with or without a vesa fb.
I can confirm that the exact same behavior (black screen with backlight on after waking up from suspend, no signal on external monitor, unless on a text console and restarting x) occurs even with vga=normal, so this does not seem to be related to a framebuffer console. Lenovo T410 with NVS3100m, Ubuntu 12.04 LTS with 302.11 driver.

As a side note: The fact that most bug reports here are using a framebuffer console probably stems from the fact that most of today's popular Linux distributions have that enabled by default. Requiring e.g. all Ubuntu users to turn off the framebuffer console manually if they want to use the accelerated graphics driver, without even a clear notice about that, sounds like a non-starter to me.
MsTiFtS is offline   Reply With Quote
Old 06-16-12, 03:03 AM   #48
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: 302.07 no resume from suspend

302.17 is still broken.
Dragoran is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[BUG] NVIDIA 302.07 console restore broken ioni NVIDIA Linux 10 12-26-12 06:02 PM
ViewPortIn and ViewPortOut in 302.07 Licaon NVIDIA Linux 14 08-05-12 05:32 AM
NVIDIA 302.07 - missing apps: nvidia-settings, nvidia-installer, nvidia-xconfig zbiggy NVIDIA Linux 3 05-02-12 04:04 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM

All times are GMT -5. The time now is 08:11 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.