View Single Post
Old 09-18-12, 07:41 AM   #4
Godlikearg
Registered User
 
Join Date: Jan 2009
Posts: 12
Default Re: K1000M on Thinkpad W530: card falls off the bus

Quote:
Originally Posted by rockob View Post
Don't you need to put 'optirun' in front of any commands you want to run with the nvidia card? For instance, lspci tells you 'unknown header type 7f' because the card is off (ie in lower power state), so if you do 'optirun lspci' you should see more useful information. If you run nvidia-settings, you also need to specify the X display to use, ie "optirun nvidia-settings -c :8".

And you shouldn't need to worry about nvidia-xconfig, just edit the config file that bumblebee is using (eg on Ubuntu it puts this in /etc/bumblebee/xorg.conf.nvidia).
optirun is only needed when you wish to run some application (e.g. a game) using the dedicated GPU. nvidia-xconfig / nvidia-smi and such commands do not need optirun as they work at a lower level.

Moreover, optirun basically what it does is running whatever it is you put after "optirun" in another X server running on the dedicated GPU, and then drawing the results back to the main display. "optirun lspci" does not make sense in this scenario.
Godlikearg is offline   Reply With Quote