nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   [BUG] NVIDIA 302.07 console restore broken (http://www.nvnews.net/vbulletin/showthread.php?t=179891)

ioni 05-02-12 12:10 PM

[BUG] NVIDIA 302.07 console restore broken
 
1 Attachment(s)
Hello,

Switching from X to tty only works one time. All the other attempts do not turn on the display.
Also shutting down is affected as well. The box doesn't turn off.
This bug appeared first time in 295.09 and all versions released have this issue.

One NVIDIA employer said that it was filled internally having no. 922163 and since then I did not get any other updates.

Is NVIDIA going to fix this issue in the near future?

towo| 05-02-12 12:29 PM

Re: [BUG] NVIDIA 302.07 console restore broken
 
I can't reproduce your problem here on debian sid.

artem 05-02-12 12:30 PM

Re: [BUG] NVIDIA 302.07 console restore broken
 
They will surely fix it, but don't hold your breath, sometimes it takes them up to a year and a half to fix a bug.

ioni 05-02-12 12:42 PM

Re: [BUG] NVIDIA 302.07 console restore broken
 
Quote:

Originally Posted by towo| (Post 2551877)
I can't reproduce your problem here on debian sid.


i'm sure you can. only old cards are affected.

towo| 05-02-12 12:43 PM

Re: [BUG] NVIDIA 302.07 console restore broken
 
You havn't written one word about your card.

gradinaruvasile 05-02-12 01:19 PM

Re: [BUG] NVIDIA 302.07 console restore broken
 
He has a
"NVIDIA GPU GeForce 8600M GT (G84) at PCI:1:0:0 (GPU-0)"
mobile card.

I have an integrated 8200 in my desktop and have no issues on Debian Wheezy/Xfce. For that matter, i never had any issues with this card.

OTOH i have a Nvidia Quadro NVS 135M in my laptop and i have a quirk: every time i wake it from suspend/hibernate, the screen does not turn on automatically unless i move the pointer or press any key (it is set to lock itself).
For a time it did a more annoying thing: It selected a wrong VT after resume (+1 or -1 vs the original one) or it respawned the x server on another VT (dunno which).
I was looking at the blinky cursor with black screen until i realized that switching to VT8 (or VT7) found my x session alive and well. This didnt look to be related to any specific driver version and it went away for good in the recent drivers.

Maybe the OP has something related.

ioni 05-02-12 01:23 PM

Re: [BUG] NVIDIA 302.07 console restore broken
 
I'm not alone with this issue. Here are my older threads related to this issue and all have replies that the bug is replicated.

295.09 http://www.nvnews.net/vbulletin/showthread.php?t=171448
295.09 http://www.nvnews.net/vbulletin/showthread.php?t=171282
295.17 http://www.nvnews.net/vbulletin/showthread.php?t=173214
295.20 http://www.nvnews.net/vbulletin/showthread.php?t=173965

artem 05-02-12 01:56 PM

Re: [BUG] NVIDIA 302.07 console restore broken
 
I'm gonna check it out soon as I also was affected by this regression.

Plagman 05-02-12 04:28 PM

Re: [BUG] NVIDIA 302.07 console restore broken
 
We pinpointed the change that caused this regression some time ago but actually finding the rootcause of the issue is still pending. I'll update this thread as soon as I have more information.

gramozeka 05-11-12 08:03 AM

Re: [BUG] NVIDIA 302.07 console restore broken
 
1 Attachment(s)
Quote:

Originally Posted by Plagman (Post 2551948)
We pinpointed the change that caused this regression some time ago but actually finding the rootcause of the issue is still pending. I'll update this thread as soon as I have more information.

I ask forgiveness for the bad English. Today is May 11, it took 4 Release 295 series, but this bug is relevant.
The parameters of my system:
CPU Intel Core2Duo E8500 3.16MGz
GPU GeForce GTS 250
Xorg-server 1.12.1
kernel 3.3.5
MB ASUS P5Q-DeLuxe
'X' in the initial startup switch to virtual consoles tty1-tty6 works. After 10 minutes of uptime can not switch - turns off the monitor. Sane solutions still do not, why?:(:(:(

P.S. at 290.10 driver everything worked fine, the problem is that he is not going to 3.3.5 kernel

dieterr 12-26-12 06:02 PM

Re: [BUG] NVIDIA 302.07 console restore broken
 
Plagman,

has this been fixed yet?


All times are GMT -5. The time now is 06:54 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.